Wix Help Center

    Feedback and issues blog feature

    Ticket by Maarten | August 21, 2014 | Feature Request
    • Hello Wix team,

      I'm been using the blog feature for a while now and I decided to sum up some issues and suggestions I came across on. Maybe the feedback can help in a new release.

      _ When selecting a different predefined font header the selection menu will disappear beneath the intro banner photo I start all my posts with.

      _ It's annoying the post needs to scroll to the top in order to use the post ribbon. Especially when writing a long post.

      _ There's no save button to save your post in between. You have to go all the way back. Better save than sorry!

      _ It would be awesome to see a preview of the post halfway before publishing.

      _ Some different types of bullet point like in Word would spice up the post.

      _ The possibility of having a hidden post you can use as a template with a header structure would be nice.

      _ It would be great if the blog feature would make use of a spellchecker somehow. (I need it :-) )

      _ A way to resize the post edit screen to make it bigger.

      _ BIG ISSUE when copy and pasting text. When selecting text and giving it a predefined header the background of the blog post becomes dark grey and unreadable. If you publish it's normal but you cannot edit in a normal way anymore.

      Thanks and keep up the awesome work,

      Kind regards,
      Maarten

    Replies (5)

    • Reply from Gan | August 22, 2014

      Hi Maarten,

      Thank you for your kind words, and feedback.

       

      I've changed your post's topic to a Wish List, so that our team can learn from your input.

      Regarding the copy paste issue- I have copied a text to your blog and it appeared like so,

      Are you able to recreate the issue? If so, please upload a screen shot.

       

      For instructions on how to take a screenshot, please use this link.

       

      To upload the screenshot, simply click on the "Upload" button and follow the steps.
       

      Please contact us for any further information.

      Best, Wix.
    • Reply from Maarten | August 22, 2014

      Hi Gan,

      Thanks for testing. I have exactly the same issue as you illustrate. This grey background makes it not easy to edit the post.

      An other thing I noticed since yesterday out of the blue. The blog feature and everything showing perfect in the preview mode and now the blog is their in edit mode but in preview or after publishing the blogs are gone and the layout is messed up :-(

      please help me restoring my blog.

      Thanks in advanced,
      Kind regards,

      Maarten

      http://maartenboonen.wix.com/sharepointpuzzles

       

       

      Rock the nation
    • Reply from Gat | August 23, 2014

      Hi Maarten,

      The issue you described was because you set both the header and the footer to a fixed position and they covered most of the screen. I've fixed it for you and saved, feel free to review the changes in the editor and publish it. 

       

      If you require further assistance, feel free to contact us again. 

       

      Gat Wix Team.
    • Reply from Maarten | August 23, 2014

      Hi Gat,

      Awesome for fixing my blog thanks a lot.
      I cannot recall I set those properties but good to know if it happens again.

      One more question. My site is loading quite slow on IE, Firefox and Chrome all latest versions. is their a recommendation of how many apps on a page indicates the loading time like more than 5 is this long and so one.

      Thanks again and I hope you guys also have a solution for the copy paste issue.

      Have a great weekend,
      Kind regards,

      Maarten

      Rock the nation
    • Reply from rotemc | August 24, 2014

      Hi,

       

      In general, please note the performance of your HTML5 site is affected by a number of factors, including the size of your website and amount of content on it, your internet connection speed and your browser version. Using the most updated browser version and ensuring that your internet connection is stable and running at a high speed will help ensure that you are viewing your site in optimal conditions.

      For best performance, it is recommended to follow these guidelines:

      1. Optimizing the images on your site will have a great effect on its performance and loading time. For tips on adding images to ensure they take up as little space as possible, please click here.

      2. Distribute your content on several pages. This will improve loading times and overall load.

       

      3. Fonts take up a lot of CPU power and loading time. Please try not to use more than 2 fonts on a single page. Fonts in plain, bold, italic, bold & italic are all considered to be different fonts! The best solution would be to use browser text and not simple text.

       

      Please let us know should you require any further assistance.

      Rotem, Wix Support Team