Wix Help Center

    For some reason when I click on the add icon button on the editor page, the blog button is not there!!! SOMEONE PLEASE HELP!!!

    Ticket by hannays9976 | September 1, 2014 | Question

    Replies (6)

    • Reply from Alissa | September 1, 2014

      Hi,

      Thank you for contacting Wix support.

      The reason why this doesn't appear is because you already added a blog to your site. Your homepage is your blog. Therefore, if your wish to add elements to your blog, all you need to do is add blog elements. From the left side of the editor on the plus to Add > click Blog Elements.

      Please do not hesitate to contact us again should you require any further assistance.

      Alissa - Wix Support
    • Reply from hannays9976 | September 2, 2014

      Thank you but I actually have a following question. So if I want to post up a blog post on a different page, how would I do that.

    • Reply from aaron | September 2, 2014

      Hi,

      Unfortunately, this isn't possible at the moment.

      We document and learn from every feature request and bug brought to our attention. These objectives are immediately high priority milestones in Wix's product road map.

      You're welcome to add your suggestion by submitting a feature request ticket.

      Feel free to contact us for any further assistance.

      Aaron

      Wix support

    • Reply from hannays9976 | September 4, 2014

      Well thank you any ways for trying to help!

    • Reply from Alissa | September 4, 2014

      With pleasure :) Please do not hesitate to contact us again should you require any further assistance. 

      Alissa - Wix Support
    • Reply from arleneneville | September 4, 2014

      with regards so this same query! If i create a "blog" page on my website ...presumably I can then post the link to this blog on say Facebook? is that right?

    Send