Wix Help Center

    Site performance issues (eg. slow loading time)

    Known Bug   |  Investigating - We’re gathering information

    Site performance is very important to us at Wix! We have recently made many changes that should improve the performance and loading time of your site.

     

    If you are still experiencing performance issues on your site, it may be because of one of the following factors:

     

    - The speed of your own connection or an overload at your ISP during peak hours
    - The amount of content on your site or home page
    -  A large number of animations and/or animated behaviors/effects on your site
    - Very large MP3 files which load on your home page
    - A slower computer (i.e. with a slow processor or low RAM) which may load the site slowly, as it cannot process the information quickly enough.

     

    In order to optimize your site for speed, try to follow these guidelines:

    - Don't use too many animations on your homepage
    - Try to use a uniform font for your site (1-3 fonts)
    - If you decide to use an MP3 on your homepage, try to use a smaller file.
    - If you use many shapes and components in the editor to create a larger image, it would be best to create a single image, with these elements, on your computer and then upload it to Wix.

     

    If, after optimizing your site for speed, you continue to experience performance issues, we ask that you please load the site using www.webpagetest.org (an independent 3rd party site that will test the speed).

     

    If you are not satisfied with the results received in the site test, and your is indeed loading slowly, please send us the link to the results, as well as your site URL. We will investigate the results and review your site. If there is indeed an issue on our end, we will do our best to investigate it and fix it ASAP. For further assistance, please post in this FAQ.

    I'm experiencing this issue Thanks for letting us know! We’ll keep you updated.

    Recent Discussions

    • Ticket by jrlee21 | 2 hours ago | 0 Replies
      I have optimized images as best as I can and the site is still super slow when loading for the first time. What can be done? Google says it is the back ground s...
    • Ticket by bambalodge | 4 hours ago | 1 Replies
      I am trying to edit my site and am constantly experiencing problems it seems to be specific to this site as I have an additional site and no problems.  It won&a...
    • Ticket by jade454 | 6 hours ago | 1 Replies
      Hello, I'm noticing that my site is having a really hard time loading on a few different galaxy tablets. It's taking up to 2 min to load the main page...
    • Ticket by kimwalmsley1 | 7 hours ago | 1 Replies
      Hi, i have not published my website yet, i am still editing it. I have upgraded to the premium package but i am having huge problems in editing the site because...
    • Ticket by dianasvasquez | 9 hours ago | 1 Replies
      It worked yesterday when I created it but today its not working. I need this to work since I am getting graded on this project! TODAY. I usually use wordpress a...