Wix Help Center

    Why is my Vimeo video not working?

    Question

    If you are a Vimeo Plus user and added  wix.com as the allowed domain, but your video no longer works (even though it previously did), please note that we're switching our static domains.

    In other words, the video is no longer coming from  static.wix.com, it's coming from  static.parastorage.com. Please add static.parastorage.com as the allowed domain in your Vimeo Plus settings.

    Yes No Thanks for your feedback!

    Recent Discussions

    • Ticket by phi596 | January 20, 2015 | 18 Replies
      I am correctly using the static.parastorage.com address in my Vimeo Plus embedded videos. I am not using a custom URL. The videos look OK in the editor and duri...
    • Ticket by crestviewfilms | January 5, 2015 | 5 Replies
      I can't get the following video to play. I assume that it's because it's a custom link? Is there any way to get this video to play?http://vimeo...
    • Ticket by meamato | November 20, 2014 | 3 Replies
      I am a vimeo plus user and I can not get the videos to work on my wix site. I changed my allowed domains to wix.com and static.parastorage.com like the troubles...
    • Ticket by 385films | September 2, 2014 | 3 Replies
      I have several vimeo links on my web site www.385films.com and they do not play on the web site.   when I go to vimeo they play fine, but not on the link on my...
    • Ticket by dbsproductions | August 26, 2014 | 2 Replies
      I am trying to add videos from my vimeo plus account.  It is exclusive content for Yelp advertisers.  However, I am allowed to add these videos to my site to sh...