Wix Help Center

    Why can't I select or delete an element in the Wix Editor?

    Question

    Often, an element will be placed behind or in front of another element. Because of this, you might have difficulty selecting or deleting a specific element. You can solve this by bringing the element forward. 

    To bring an element forward: Click the element > from the pop-up menu, click the Bring forward icon. You will, then, be able to move, edit or delete the element.

    Alternately, if you are unable to click the element to select it, click the element in front of it > click the Send backward icon to send that element behind the element that you are trying to access.

    For an element in your header, when unchecking the Show on all pages box, the element might move behind the header causing it to appear inaccessible. To access the element, move the header backwards as described above or use Ctrl + M to toggle through the elements on your page until the element is selected.

    If you are still unable to select the element, please submit a ticket below and we will assist you further.

    Yes No Thanks for your feedback!

    Recent Discussions

    • Ticket by mintchocolate | One hour ago | 0 Replies
      Help! I cannot delete a "Let's talk" section on my site. I have followed every instruction listed within the help section and also read the previ...
    • Ticket by egibson8202 | 2 hours ago | 0 Replies
      I put in two buttons one was a document the other was a QR code and I want to delete them but I cant even when I send the page backwards
    • Ticket by stephotoexp | 13 hours ago | 1 Replies
      Help I cant delete an image on my website, it appears on every page and tried to select it but cant to bring forward or back, please help,Steve Davies
    • Ticket by timsands2 | 15 hours ago | 4 Replies
      an image I added to a page on my site now shows during loading of each page and also displays under the pictures on my home page for no reason I cant select it...
    • Ticket by kevinjmsmith | 18 hours ago | 1 Replies
      Hi, I added an html box to my contact page with a conversion tracking code for Google Analytics. The code is working fine but I think I may have duplicated this...