Wix Answers

Do not post confidential info such as passwords or financial information.
Cancel
Post Question
wix Wix Team

If your Contact Form is not working, please try the following:

 

1. Check to see that you have entered the correct email address in your Contact Form settings.

To check your Contact Form email address: Click the Contact Form that you added to your site > in the Settings window, under Email To, enter or correct the email address that you want Contact Form submissions sent to.

Make sure to Save and Publish if you make any changes.

 

2. Check that emails sent through your Wix Contact Form are not being recognized as spam and have ended up in your Spam/Junk/Bulk Folder.
 

Note: If the email address you added is example@YourSiteDomainName, make sure that the MX records are pointing correctly, click here to learn more.
 

For more information on using Contact Form, click here .

Replies(145 replies total)

Show my replies first
  • chrisrenee06

    Replied by chrisrenee06 April 12, 2014

    Hello, 

    I recently had my website transferred over to me from a friend, everything is working great except the "contact form". 

    • shayb7 Wix Team

      Replied by shayb7 April 12, 2014

      Hey,

       

      In order to provide you with the highest level of support and service, we require additional information. Please elaborate as to the nature of the problem and provide us with a detailed outline of the steps required to recreate the issue on our end as well as with screenshots exemplifying the issue so we could better understand and further assist. You can find step by step instructions here.

       

      Awaiting your reply

    • chrisrenee06

      Replied by chrisrenee06 April 12, 2014

      Looks like it is actually working as of late last night. It was just very slow, a few hours behind. I will contact you if anything else goes wrong. Thanks 

    • AlonH Wix Team

      Replied by AlonH April 12, 2014

      We are glad to hear that the issue has solved.

      Don't hesitate to contact us if you need any further assistance.

  • cr9245

    Replied by cr9245 April 5, 2014

    My contact form is working for most, but the few people who can't get it to work are all using Macs with the latest OS. They have tried in Safari, Firefox and Chrome. When they click on a field to type, nothing appears. Here is the link to the page having the issues: http://www.folkwest.com/#!pfb-volunteer/c11dq

     

    • ilan-t Wix Team

      Replied by ilan-t April 5, 2014

      Hello,

       

      Could you please let us know if they receive any errors? Including a screenshot would help in investigating the matter also.

       

      Best regards

  • sirphoto

    Replied by sirphoto April 5, 2014

    My Contact form isn't working.  I sent a message to myself using my wife's e-mail address, twice.  I never received either message at the e-mail address that I listed on the Contact form.  That e-mail address is functioning, and no, the message was not intercepted my my ISP's spam filter.  Can you help?

    • Ilia Wix Team

      Replied by Ilia April 5, 2014

      Hi,

      I've sent you a test email through the contact form. Please let us know if you've received it.

      Also, Please try and ask Comcast if they are blocking any emails from

      no-reply@parastorage.com

       

      Best regards

      Ilia - Wix Support
    • sirphoto

      Replied by sirphoto April 6, 2014

      No, I haven't received it.  I also have access to the e-mail's blocked by Comcast's span filter, and there are no e-mails stored there.

    • Ilia Wix Team

      Replied by Ilia April 6, 2014

      Hi,

      Do you have any other email address you can try and configure the contact form to?

      Also, I advise contacting Comcast and asking them if you have another filter except for the Spam filter. Sometimes ISPs block certain addresses and the spam filter has nothing to do with this since the emails don't even reach the address.

      Ilia - Wix Support
    • sirphoto

      Replied by sirphoto April 6, 2014

      I changed the e-mail address to my iCloud address.  Sent another test message using my wife's e-mail.  Still doesn't work.

    • Ron Wix Team

      Replied by Ron April 7, 2014

      Hi,

       

      I've tested your contact form with my own personal email address, it worked flawlessly.

      I suggest that you create a dummy gmail account and test it out with that email address and it appears that something may be blocking your emails in your email account.

       

      Let us know how it went and if you require further assistance.

       

      Ron, Wix Team
  • katieannbeckett

    Replied by katieannbeckett April 3, 2014

    My enquiries are not being emailed to me

    I have clients ringing me wanting to know why I have not responded to their email enquiry through the website. I am not getting the enquiries.

    • CarleyS Wix Team

      Replied by CarleyS April 3, 2014

      Hi katieannbeckett,

       

      I have merged your post to the thread on this topic. Please see the Best Reply above for more information.

       

      In addition, I have sent a test email through your Contact Form. Please check for this mail both in your inbox and your spam folder.

      - Regards, Carley
  • chevvyallen

    Replied by chevvyallen April 1, 2014

    I've done everything I need to do - it still want work - it won't submit - it highlights the phone number and says invalid email

    • Marina Wix Team

      Replied by Marina April 1, 2014

      Hello,

      I was able to properly use the contact form and send a message as you can see here:

      Please note that you've made the Phone and Email fields mandatory. If you haven't filled these fields, you will receive these error messages.

      the mandatory fields are set via the contact form settings (go to the editor --> Click the contact form --> 'Settings' --> under 'Customize form fields' select the mandatory ones). 

       

      Please provide us with steps for recreating the problem if you're still experiencing this issue. 

  • suefrankw

    Replied by suefrankw March 29, 2014

    My contact form is not working. I have checked email and they are correct. They form was one in the templates. I did not create it it was a template.

    I have tried twice. It says sent successfully but I did not get it.

    www.theartisantavolo.com

    thanks

    • suefrankw

      Replied by suefrankw March 29, 2014

      and it is not in spam. And my site was saved and published

    • Dima Wix Team

      Replied by Dima March 29, 2014

      Hi,

      I've just sent you a test message. Please take a look and tell us if you got it. Also, is this email account correctly set up? Are you able to send and receive mail from other sources? 

      Dima -Wix support team-
    • suefrankw

      Replied by suefrankw March 29, 2014

      Hi

      thanks I did not get the message at the primary email but did get it at the 2nd email I listed. The 1st email is an aol email. Might that have something to do with it? And why when I sent 2 from the published website did they not go thru to either email.

      thanks

    • Or Y Wix Team

      Replied by Or Y March 30, 2014

      Hello,

       

      The AOL issue may be addressed on the following thread: Contact form not sending to AOL mailboxes 10/12/13.

       

      I have just sent you a test message, it says the message has been successfully sent. Please check both your inboxes.

      Please elaborate in regard to your second question - in what case has the email not been delivered to both addresses?

       

      Thanks and I await for your reply.

      All the best, Or
    • suefrankw

      Replied by suefrankw March 30, 2014

      thanks for your help. your email did come thru but not to the aol address. I know aol can be difficult. I will redo and eliminate aol.

      appreciate your prompt response.

      Sue

    • Natty

      Replied by Natty March 31, 2014

      Hi Sue,

      We have contacted AOL and they assured us that the problem has been resolved. Unfortunately, we can see that the issue is still persisting.

      We will contact them again and will update this thread.

      Thank you for your understanding.

  • harrypm1982

    Replied by harrypm1982 March 28, 2014

    My contact form sends and ive tried different emails as i have a 123 reg email and a gmail account. I've done the pointing thing and added the main email address to send and bcc to my gmail but receive nothing after sending?

    • harrypm1982

      Replied by harrypm1982 March 28, 2014

      I've also saved and published after each change

    • Dean Wix Team

      Replied by Dean March 28, 2014

      Hey,

       

      Using my own email address on your contact form I was able to receive a message.

      Please try your personal email address and let us know if you get the same error.

      If you can send an email to a different mail address then the solution may reside in your email configuration.

      Can you send emails to these mail boxes outside the contact form?

       

      Awaiting your reply.

      All the best, Dean - Wix Team
  • nkseery

    Replied by nkseery March 26, 2014

    3 of my 6 pages will not load, online.  They are saved and published and look fine on the Editing site but not working. Any ideas?

    • dinamiso Wix Team

      Replied by dinamiso March 26, 2014

      Hi,

      I assume you are referring to the site: cqworlds.com ?

      Please note: The pages are not loading, as the menu buttons are covered by a text box.

       

      In order to solve this issue, please resize the box to a minimum size:

       

      Dina-Wix Team.

  • readmclean

    Replied by readmclean March 25, 2014

    Hi there, 

    Unfortunately I am unable to receive emails via my contact form - I noticed earlier in the thread a user was having a similar issue: My form will say the details/email has been sent successfully, however the email does not reach any of the three devices I have the contact form directed towards. Correct email is set etc. 

    MX tables are updated. Can you please advise? 

    http://www.brigandintel.com/#!contact/c2q4

    • readmclean

      Replied by readmclean March 25, 2014

      Nevermind, i've updated the MX with additional info. Problem should be solved in the next few hrs. Thanks anyway. 

    • Or Y Wix Team

      Replied by Or Y March 26, 2014

      I am glad to hear the issue is solved, please let us know should you need any further help.

      All the best, Or
    • Ritti Wix Team

      Replied by Ritti March 26, 2014

      Hi,

      Please let us know should you still have difficulties.

      Best, Ritti
  • dabijaanca

    Replied by dabijaanca March 24, 2014

    Hello,

    My contact form have also problems. I can't complete the field "Name"  it can t be writable. I already made this field mandatory as well as the others fields....so my error message is "Please fill in all required fields."

    http://dabijaanca.wix.com/mediator-erciu-maria#!contact/c17jp

     

    • CarleyS Wix Team

      Replied by CarleyS March 24, 2014

      Hi dabijaanca,

       

      The reason that the "Name" field on your Contact Form was not working was that the text box above it covered it as can be seen in the screen shot below:

      I moved this text box up for you and saved your site, however I have not yet published. If you are happy with the change, please click Publish from inside your Editor.

       

      If you need any further assistance, please let us know.

      - Regards, Carley

Add reply

Mark this reply as Best Reply
Close open child tickets
Post reply