Wix Answers

Do not post confidential info such as passwords or financial information.
Cancel
Post Question
wix Wix Team

HTML5 is finally here!

You can create your HTML site now by clicking 'Templates' and choosing an HTML template. For more information on how to get started, click here or check out the below video!

 

We're excited to hear your feedback, simply post in our HTML Forum

 

 

Replies(177 replies total)

Show my replies first
  • victors12

    Replied by victors12 January 28, 2014

    <iframe src="//player.vimeo.com/video/76619440" width="500" height="281" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe>

    • Eyal Wix Team

      Replied by Eyal January 28, 2014

      Hey victors12,

       

      To add a video to your site:

       

      1. From the left side of the Editor, click the plus sign to open Add.
      2. From Add, click Media.
      3. From Media, click Video.
      4. From Video, under Video URL, type or paste the URL of your video.
      5. Click Update.
      6. Click outside of the video to close the Video settings window.

       

      A video is added to your site.

       

      To return to Add, click Back to Add from the top of the Media window.
      To close Add, click X from the top right.

       
      * Note for YouTube videos: From your YouTube video's settings, make sure that your video is set to 'Public' and that the 'Allow Embedding' box is checked (in Advanced Settings). 
      Also make sure not to use the video's full screen link as it will not work in Wix's video player.
       
      For more information about videos click here or watch the video below:
       

      You can also try any of the video apps in the App Market: ViewBix, TubePress and iPlayerHD. Click here for more information about adding apps to your site.

       

      If you have any other questions, please let us know!

      Thank you,

      Eyal, Wix Customer Support Team
  • sudarshana1975

    Replied by sudarshana1975 January 23, 2014

    I need help asap. I have been trying to edit my site. the html 5 is taking the whole day to upload on my laptop. i simply van not edit anything on my site..help please..

     

    thanks sudarshana

    • Nat

      Replied by Nat January 23, 2014

      Hey Sudarshana,

       

      If you are unable to load the HTML editor for your site, please try troubleshooting with the following steps:

      1. Try using another browser, such as Google Chrome or Mozilla Firefox.

      2. If it does not load in several browsers, please try using another internet connection (if possible). Sometimes the router or network's firewall may block the connection, and this is usually an easy way to test if this is the case.
      If you have access to your router and modem, you can try connecting to the modem directly (i.e. plug the ethernet cable from your modem into your computer) in order to see if the router was causing the issue.

      3. Try editing another site. Are you able to? If you don't have another site, please go to the 'create' page of Wix.com and try to edit a new template. 
      Are you able to load the editor for other sites, or do you experience this problem for all websites?

      4. Check your Antivirus and Firewall software. Try temporarily disabling them (for 2-3 minutes) and then edit your site. Was this blocked by the Firewall or Antivirus on your computer?

      5. If you use the same extensions in several browsers, please try disabling all of the extensions in any one browser and then edit your site.
      Alternatively, if you have Google Chrome installed, you can open a new Incognito window (ctrl+shift+n in windows) and log in to your account. Can you edit your site now?


      If you still experience this issue, please let us know and also tell us which of the above steps you've already gone through so that we can continue to assist you in resolving the problem.

      Please don't hesitate to contact us again. Nat
    • sudarshana1975

      Replied by sudarshana1975 January 23, 2014

      hi,

      thanks for your reply, but none of the above work. It has to do something with WIX.

      I paid quite a lot of money, and am really upset if I can not use it. I am an artist and will have an exhibition going on from next month. It is extremely urgent for me to have the website up and running.

      Hope you understand. Please help.

      Thanks

      sudarshana

    • Ritti Wix Team

      Replied by Ritti January 23, 2014

      Hi,

      I was unable to recreate this issue on my side and the editor loaded quickly.

      What browser are you using? Do you have this issue on other browsers as well?

      Can you check if you have this issue on a different computer as well?

      It is critical for us to get more information from you in order to investigate this issue. Please let us know what the steps were you have taken in order to solve/check this and what device and operating system you are using as well.

      Thank you for your cooperation.

      Best, Ritti
  • makingbeautyb

    Replied by makingbeautyb December 6, 2013

    IN NEED OF HELP PLEASE! I understand wix now has a "HTML" option to work on iPhone and iPad devices. I am wondering how to upload images onto my site via iPhone or iPad as my computer loads them very slow! I tried everything does the app "blogsy" work? Helppppppp

    • Keren Wix Team

      Replied by Keren December 6, 2013

      Hey,

       

      Thank you for contacting Wix support!

      We do not provide the option of working from an iPad nor Smartphone. It is recommended to build your site using a computer and creating a mobile editor from there. 

      We’re excited to bring you an amazing feature that automatically takes your HTML website and creates an optimized version for mobile view. Click here for more information or watch the video tutorial below.
       


      If you are looking for our previous mobile site solution, you can still access and edit it from My Account. For more information, click here.

      Please don't hesitate to contact us if you require any further assistance.

      Keren, Wix Support
  • fedupbyfriday

    Replied by fedupbyfriday December 4, 2013

    hi everyone.

    im trying to add my opt in box from aweber to my wix site. I added it in the html box and it worked perfectly, however when the submit button is hit, it only redirects in the parameters of the html box. how can i make the whole entire page redirect rather than just the tiny box?

    • Jo Wix Team

      Replied by Jo December 5, 2013

      Hi fedupbyfridaym,

      This is not possible, since the HTML App is an embedded component on your site. 

      Instead, you can request that after users hit the submit button, a new window opens. Note that you will need to configure this before inserting the code to the HTML App in the Wix editor, and we are unable to assist you further. 

  • 1clicsolution2013

    Replied by 1clicsolution2013 November 13, 2013

    How can I add the following link to my webpage as this is a benefit to my business.

    <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
    <!-- 1 Clic (1) -->
    <ins class="adsbygoogle"
         style="display:inline-block;width:728px;height:90px"
         data-ad-client="ca-pub-3213003201428778"
         data-ad-slot="6652114446"></ins>
    <script>
    (adsbygoogle = window.adsbygoogle || []).push({});
    </script>

    • Gat Wix Team

      Replied by Gat November 13, 2013

      Hi 1clicsolution2013,

      • With the HTML App you can test and add your own HTML code to your Wix site.

        For more information check out the tutorial below, or you can click here.
         


        *Take a minute to read through the Known Issues & Limitations of the HTML iFrame/Embed App via the link above before using this.

      Gat Wix Team.
  • glindholm1

    Replied by glindholm1 August 19, 2013

    Hi

    I have added the html app and added the code. The was very simple. But it doesnot work as it should. It is really unstable, sometimes it occurs on the site ,but sometimes not. It works on my mobile for example. It seems to be connected to how I view the site, from which computer

     

    I cant have it like that, I rely of the functionalit yof the site. And the loading is always very slow. It has to do something with the Wix. This is critical for me, otherwise I am not interested to use the wix. Please reply to this soon

     

    Kindly

    Göran

     

     

    regards

    Göran

    • Nat

      Replied by Nat August 19, 2013

      Hey  Göran,

       

      If the HTML app isn't working, it may be a problem with the code. You can check if the code is correct by using  this site.
       
      Simply paste the html code between <body> RIGHT HERE </body> and click the button above (Edit and Click Me) in order to see the results.
       
      If nothing appears in the right window or a certain component appears but doesn't work, this means that the code is problematic. Please contact the creator of the code and let them know that it isn't working.
       
      If the preview shows the content as expected, then it's a compatibility issue with Wix. We're currently working on improving the compatibility of Wix with customizable code.
      Please don't hesitate to contact us again. Nat
    • glindholm1

      Replied by glindholm1 August 19, 2013

      The code is working fine on the test site. So it is the Wix compability that fails.

      This is really critical since I guess it is common that people add html codes with important features for their sites. In my case it is a disaster without the working html-code.

      What is the plan to fix this?

      Time schedule?

    • Yotam Wix Team

      Replied by Yotam August 19, 2013

      Hi Göran,

      Please keep in mind that by adding  external HTML code  you are adding products and code that we have not tested or created  in  Wix, therefore our support team cannot answer any questions concerning the HTML  iFrame /Embed  App.

       

      If you require any further assistance, feel free to contact us again. 

       

      Yotam Wix Team
  • awalkforestelle

    Replied by awalkforestelle June 14, 2013

    My website is up and running ok, but now when I want to go into my website on HTML 5 its taking forever, I cant edit my website or anything..  All Im getting is HTML 5 and its just downloading (as such)  HELP,  I need to get onto my site so I can give people news etc 

    Thanks 

    • Niv Wix Team

      Replied by Niv June 14, 2013

      Hi,

      I checked your editor and I didn't experience any loading issues.

      Please be more specific regarding the issue you are having.  Have you tried using another browser to preview your site?  Are you having this issue using a specific computer or internet connection?

      In addition please make sure to clear your cache.

      Thanks,

      Niv, Wix Support
    • awalkforestelle

      Replied by awalkforestelle June 17, 2013

      When i click on edit site, it opens another tab (which it usually does) and all have in middle of screen is 5 little symbols and loading editor.  it wont go straight to my website when i want to edit it :-(  

      Thanks 

    • Hudson Wix Team

      Replied by Hudson June 17, 2013

      If it is these images which are being shown to you, this is while the editor is loading,

    • awalkforestelle

      Replied by awalkforestelle June 17, 2013

      Yes it these images and half an hour later its still there and not going to my website.. Ive cleared everything on history, cache, the works and still nothing happening :-( 

    • Yoav Wix Team

      Replied by Yoav June 17, 2013

      Hello,

       

      I have been able to access your site using the Wix Editor, which means you must be experiencing some local difficulties.

       

      Do you experience this issue using more than one browser? Please try using different ones such as Google Chrome, Internet Explorer 10 or Firefox and see if it helps.

      You can also try temporarily shutting down any firewalls or internet security software you might have installed - or connect your computer to the network using a wired connection, instead of Wi-Fi.

       

      Let us know if the problem persists so we could further assist you!

  • contactdella

    Replied by contactdella May 30, 2013

    You created an html version of my site.  Sorry to say it looks terrible, nothing like the original site.  I did not publish it.  I wanted to see how it would look because I was advised that due to the Flash aspect of the Wix sites, the search engines have problems finding it or seeing it.  Suggestions?

    • Eyal Wix Team

      Replied by Eyal May 30, 2013

      Hi contactdella,

       

      Please note that our Flash to HTML 'conversion' is in a very early testing phase, and this was pointed out on the page where you submitted your request to convert your site. You can find this information by clicking  here

       

      The best alternative at the moment is for you to chose a new HTML template and copy all your big chunks of text from your Flash site to a text editor as a 'middleman', then paste it on to your HTML site. 

       

      We are sorry for the inconvenience, if you require any further assistance please let us know!

      Thank you

      Eyal, Wix Customer Support Team
  • celestialteapotmag

    Replied by celestialteapotmag May 5, 2013

    Hello, I'm trying to paste some custom HTML into the window and it works well, but it automatically gives those annoying little arrows for up and down and left and right scrolling. I understand those are needed for iFrames, but for custom code that  is simply creating an widget or button or object that shouldn't have any scrolling features. Is there some way I can get rid of those sidebar arrows?

    • Nat

      Replied by Nat May 5, 2013

      Hey,

       

      We cannot provide support for external codes.

      Please don't hesitate to contact us again. Nat
  • mandyzdandy06

    Replied by mandyzdandy06 April 18, 2013

    Okay, so here is my quandry...
    I just designed an html5 site using wix and went to preview from the 
    my account/site/preview
    direction and all I got was the background, header content, footer content. None of the body content loaded plus none of the links in the header content worked (as I expected due to the fact that none of the body content loaded). I was able to see the drop down menu's so thats a plus I suppose. 


    However, when I go to preview from within the HTML5 editor I get the whole page. (all the content) 
    Whats Up?
    This confuses me.

    This site is for my dad who has a book going live the beginning of next month so I want to be able to transfer it to his own wix account before making it live (since you can't do that afterwards) My concern is that after I transfer it and make it live all I am going to see are the background and header footer content. If that is the case I do not want to go through the hassle of making live a site that isn't going to work properly. (Yes even with your wonderful manager its a hassle)

    Please some insight here. Is it just the preview feature that isn't loading correctly or is that indeed what is going to happen to the sight. 

    Also WIX should post a disclaimer that there have been uploading and content errors in your current beta version to warn people before they spend hours creating a site in a beta that they are under the assumption actually works only to have to recreate the site in flash or another template/hosting service. That is twice the work and twice the time that most of us do not have to waste. HUGE let down on this one guys. 

    I use WIX daily for a family site, wedding site, and work site.
    This is very frustrating. Great in theory though!

    • mandyzdandy06

      Replied by mandyzdandy06 April 18, 2013

      Also the HTML 5 test page that a previous poster provided works just fine on my computer and browser (google chrome) 468 out of 500. 

    • mandyzdandy06

      Replied by mandyzdandy06 April 18, 2013

      I just checked one of my other HTML5 sites under development and the preview on that site is working so I am left to believe that it is the template that I chose that is not working properly or just my site and am wondering if one of you wix folks has an answer. 

    • mandyzdandy06

      Replied by mandyzdandy06 April 18, 2013

      UPDATE

      I bit the bullet and decided to publish the site. Thankfully it turned out just fine.
      For others having an issue with the 'Preview Site' feature from the main page chances are it is just the feature that is error-ing for some reason. 
      Note that preview was working from within the wix editor just not from the main account menu. I did a lot of troubleshooting trying to figure out if it was caused by an add on or not but nothing changed with any setting changes or removals so... meh.

      Thanks! *even though I figured it out before any wix people got the chance to help.*

Add reply

Mark this reply as Best Reply
Close open child tickets
Post reply