Wix Answers

Do not post confidential info such as passwords or financial information.
Cancel
Post Question
wix Wix Team

If you are experiencing performance Issues with your HTML Site, please post your issue in this thread.

 

At Wix, we strive to provide the best services possible for you and your website's visitors.

 

We hold performance related issues in the highest regard and we are constantly working to improve the loading time and overall performance of sites built with our platform. Rest assured this is our top priority and we are currently working on a major update to address this issue. This update should be released in our next core version.

 

If your website takes more than 5-7 seconds to load, please go to www.webpagetest.org and run a test for your site. Once you receive the results, please post a link to the results here.


Thank you for your patience and understanding.

Replies(3,058 replies total)

Show my replies first
  • ceilingau

    Replied by ceilingau 5 days ago

    loading slow on mobile version

    Hi,

    The loading speed of my site with Ecwid embed is satisfied, but it is very slow on mobile devices which freezes for 6-10 seconds...even more. Could you please help check and advise how to improve? Thanks in advance. 

     

    domain: www.wasabeauty.com

    webpagetest result: http://www.webpagetest.org/result/140717_74_Q5F/

    • Elia Wix Team

      Replied by Elia 5 days ago

      Hi, 

      Speed issues can be related to the test server itself, it's GEOlocation and more parameters such as ISP, traffic congestion etc.

      Here is a speedtest for your site.

      As you can see from the results, your site took 9.136s fully load, making 156 requests and downloading 3,048 KB of content.

       

      3,048 KB is a lot of content for a homepage, and I recommend optimizing your first page to be more lightweight.

       

      I recommend trying to optimize your site. (If you wish to experiment with it, you can have your site duplicated.)

      In order to speed up your site, you may try the following suggestions: add a landing page to your Wix siteOptimizing your images, and reduce the amount of content at your homepage (add more pages as necessary to complete your visitors experience with your website).

       

      If you have any further questions, please let us know.

      Elia - Wix Support
  • buffiayoung

    Replied by buffiayoung July 17, 2014

    My site isn't loading at all...can you please help us? Here is the test I ran...notice the screenshot is blank. It never loaded.

    http://www.webpagetest.org/result/140717_2N_KV4/

    Thanks!

    Buffi

    • Nitzan Wix Team

      Replied by Nitzan July 17, 2014

      Hi Buffi,

       

      I have checked your site with another a speed test, the results of which can be seen here. Please note that your site received a score of 'A' in all criteria. Additionally, the screenshots now appear in the test results.

       

      While browsing on the web, your computer and browser stores various information. This build up of information can sometimes cause conflict.

      Please clear your browser's cache. You can find step by step instructions here.

       

      Please let us know if the issue persists, or should you require any further assistance.

      Have a great day! Nitzan - Wix Support Team
  • contact3611

    Replied by contact3611 July 17, 2014

    Hello

    My site was loading quite fast until a week or 2 ago and now it takes 10 to 12 seconds to load the first page.

    I ran the test website but I'm not sure how to interpret the results.

    The first page of my site used to have a 3 images gallery, I changed it to 2 but it didn't seem to improve the speed. It actually seems like it's the background image that is long to load (image from wix gallery)

    Your help would  be much appreciated

    http://www.webpagetest.org/result/140717_ES_K5K/

     

     

     

    • contact3611

      Replied by contact3611 July 17, 2014

      my site is url is www.nougatine.com.au

      btw, what is a progressive jpg? we tried to follow wix recommendations for images sizes and format but this appears as a fail in the test.

      Thanks

    • rony Wix Team

      Replied by rony July 17, 2014

      Hi, 

      Speed issues can be related to the test server itself, it's GEO location and more parameters such as ISP, traffic congestion etc.

      Here is a speedtest for your site.

      As you can see from the results, your site took 14.062s fully load, making 116 requests and downloading 6.029 KB of content.

      I recommend trying to optimize your site. (If you wish to experiment with it, you can have your site duplicated.)

      My suggestions are to try to add a landing page to your Wix siteOptimizing your images, and reduce the amount of content at your homepage (add more pages as necessary to complete your visitors experience with your website). Note that the content being loaded is considerably heavy.

       

      Also, your site received a score of 'F' for progressive .jpegs. For information about Progressive Jpegs click here.


      To rectify this, you will need to save your images in progressive .jpeg format. If you are using Gimp to improve your image quality, you will be able to make these changes in the Advanced Options section.


       

      If you have any further questions, please let us know.

      Rony WixTeam
    • contact3611

      Replied by contact3611 13 hours ago

      Hello Rony,

      Thanks for your reply.

      I duplicated the site, reran all jpg through gimp to make sure the progressive option was selected.

      The results are still the same and have a look at this

      One images takes almost 7 second to load. This is the background image provided by wix. So I didn't touch this one thinking it would already be optimised and in progressive jpg.

      Can you have  a look?

       

      site

      contact3611.wix.com/nougatine-prod2

      Test

      http://www.webpagetest.org/result/140723_F0_1HG/1/details/

       

    • contact3611

      Replied by contact3611 12 hours ago

      Also, Wix favicon takes 1.2s to load.

      And there are many things hapening before the document complete line at 5s, but it doesn't seem to be related to the site content or images. How do I decrase this time?

       

      Thanks

    • rony Wix Team

      Replied by rony 4 hours ago

      Hi, 

      I performed a web test and the site is loading in 6.174s. Which is great! 

      There are 3 non progressive images on your site. You check them in here.

      Overall the performance of your site is correct according to its size and content.

      In case of further questions, please contact us again. 

      Rony WixTeam
    • contact3611

      Replied by contact3611 3 hours ago

      Hello,

      it is now 6.17s because I replaced the background image provided in the editor by a plain black colour.

      Is there a way the background image could be fixed?

      Also is there a way to know which images are not progressive? I was sure I modified all the images to be progressive.

      Thanks

    • rony Wix Team

      Replied by rony One hour ago

      Hi, 

      Using an optimized background should not strongly interfier with your site's speed.

      You can check the non progressive images in here. Just copy and paste the given links  in your browser to see the image.

      Rony WixTeam
  • jamadots Premium VIP

    Replied by jamadots July 17, 2014

    My site, although still unpublished, is loading very (painfully) slowly. I work for a telecommunications company and have a download speed of 90 Mbps. Please help. I want to ake my site live in the next few days but, need to make sure the speed is sufficient to satisfy and impress customers. Here is the 'Share Your Site' link. http://bit.ly/1oZU2vf

    • Barrios Wix Team

      Replied by Barrios July 17, 2014

      Hi,

       

      Thank you for contacting the Wix support team.

      Are you referring to the editor? please see What browsers are compatible with Wix?

      While browsing on the web, your computer and browser stores various information. This build up of information can sometimes cause conflict.

      Please clear your browser's cache. You can find step by step instructions here.
       

      Should the problem persist please provide us with a screen shot of the problem. For instructions on how to take a screenshot, please use this link.

       

      To upload the screenshot, simply click on the "Upload" button and follow the steps.
       

       


      Feel free to contact us with any questions you may have.

      Many thanks, Barrios
    • jamadots Premium VIP

      Replied by jamadots July 17, 2014

      I just cleared my cache and history. I hit Site Preview and timed the load time with a stopwatch. It timed at 24.5 seconds to load the homepage.

    • Adam E. Wix Team

      Replied by Adam E. July 17, 2014

      Hi,

      Unfortunately we were unable to recreate this loading issue on our end. 

      This issue could be caused by a variety of factors.

      To help us pinpoint its source please follow the instructions provided here.

      If the steps in the link didn't resolve your issues, please answer the questions in the same link.

       

      Thanks,

      Adam, Wix Support
  • smcmahan

    Replied by smcmahan July 17, 2014

    First Byte Time got an F while the others got As.  So what is that and how can I (or we) fix it?  Thanks!

    Suzanna Upcycled Vintage Jewelry suzannamcmahan.com
    • smcmahan

      Replied by smcmahan July 17, 2014

      http://www.webpagetest.org/result/140717_DQ_9F3/

      Suzanna Upcycled Vintage Jewelry suzannamcmahan.com
    • Rapido Wix Team

      Replied by Rapido July 17, 2014

      Please do not post in multiple threads regarding the same issue. I am replying to you here

  • uchihabeep

    Replied by uchihabeep July 17, 2014

    My Wix site verry slow

    lost 8s -15s to load my Wix site . internet 10mb/s .  

    • Nati Wix Team

      Replied by Nati July 17, 2014

      Hi uchihabeep,

       

      Thank you for contacting us regarding this matter.

       

      Please note that I have merged your post into the relevant thread concerning this matter.

       

      I have checked your site using a speed test, the results of which can be seen here.

       

      As you can see in the test results, your site scored an F on both criteria related to the images on your site.

       

      To ensure that you maintain the quality of your photos and decrease loading time to a minimum when uploading to Wix, please follow the guidelines here.

       

      If you are still experiencing performance issues on your site, it may be because of one of the following factors:

      - The speed of your own connection or an overload at your ISP during peak hours
      - The amount of content on your site or home page
      -  A large number of animations and/or animated behaviors/effects on your site
      - Very large MP3 files which load on your home page
      - A slower computer (i.e. with a slow processor or low RAM) which may load the site slowly, as it cannot process the information quickly enough.

       

      In order to optimize your site for speed, try to follow these guidelines:

      - Don't use too many animations on your homepage
      - Try to use a uniform font for your site (1-3 fonts)
      - If you decide to use an MP3 on your homepage, try to use a smaller file.
      - If you use many shapes and components in the editor to create a larger image, it would be best to create a single image, with these elements, on your computer and then upload it to Wix.

       

      We are here should you need any further assistance.

      Best Regards, Nati - Wix Support Team
  • kmhover

    Replied by kmhover July 17, 2014

    domain does not load

    My site is loading extremely slow and my images are not loading at all. Please help,

    Kelly

  • kmhover

    Replied by kmhover July 17, 2014

    My website is www.foodtoyourfridge.com

    • Or Y Wix Team

      Replied by Or Y July 17, 2014

      Hello Kelly,

       

      I have merged your post with the relevant thread. Please read the Best Reply herein above, and let us know in case the slow performance issue persists.

      All the best, Or
  • midhydroponic

    Replied by midhydroponic July 16, 2014

    very very slow to load page. most people will just turn off it never was like this?
    • Ritti Wix Team

      Replied by Ritti July 17, 2014

      Hi,

      I visited your site and it loaded quickly for me. Please refer to the best reply above for further instructions.

      Best, Ritti
  • agarofalo2001

    Replied by agarofalo2001 July 16, 2014

    Hello my home page is taking a long time to load.  Suggestions?  www.garofalolaw.net

    • Nati Wix Team

      Replied by Nati July 17, 2014

      Hi agarofalo2001,

       

      Thank you for contacting us regarding this matter.

       

      I have checked your site using a speed test, the results of which can be seen here. Moreover, I have accessed your site and I can say that overall your site loads pretty fast and performs very well. 

       

      If a site is taking between 5-7 seconds to load, it is considered good performance and you site loads within 3.752s for first view and 1.497s for repeat view.

       

      In general, please note the performance of your HTML5 site is affected by a number of factors, including the size of your website and amount of content on it, your internet connection speed and your browser version. Using the most updated browser version and ensuring that your internet connection is stable and running at a high speed will help ensure that you are viewing your site in optimal conditions.

       

      For best performance, it is recommended to follow these guidelines:

       

      1. Optimizing the images on your site will have great affect on its performance and loading time. For tips on adding images to ensure they take up as little space as possible, please click here.

       

      2. Distribute your content on several pages. This will improve loading times and overall load.


      3. Fonts take up a lot of CPU power and loading time. Please try not to use more than 2 fonts on a single page. Fonts in plain, bold, italic, bold & italic are all considered to be different fonts! The best solution would be to use browser text and not simple text.

       

      We are here should you require any further assistance.

      Best Regards, Nati - Wix Support Team

Add reply

Mark this reply as Best Reply
Close open child tickets
Post reply