Wix Answers

Do not post confidential info such as passwords or financial information.
Cancel
Post Question
wix Wix Team

There are three possible solutions:
1. If your domain is pointed to Wix by IP- Please contact your domain hosting company and ask them to remove the MX records that point to Wix.
2. If you are connected via Name Servers- Please ask your domain hosting company for the MX records and insert them here .
3. If you have purchased personalized emails from Wix, please follow the instructions here.
You can also find FAQ's here.

 

In order to get your personalized email address up and running please follow the instructions here.
You’ll find clear instructions on how to connect to email via Yahoo Mail or GoDaddy here:

Connect to email via Yahoo
Connect to email via GoDaddy
 


 

Note:  Please note that it might take up to 72 hours to be updated.

 

 

Replies(665 replies total)

Show my replies first
  • montserratbartoli

    Replied by montserratbartoli January 31, 2014

    Hi,

    I have my domain www.carnisseriacodina.com and my web page in Wix. Also, I have my own provider of mail service and I try to connect it but doesn´t work correctly.

    Somebody can help me!

    Thanks,

    Montse.

    • Michal

      Replied by Michal January 31, 2014

      Hey Montse, 

       

      Thank you for posting!

      Please contact your email provider and ask them for any A and MX records that need to be added to your domain records in order to connect your email. Then send them to us, and we will be happy to add them for you. 


      Thanks,

      Michal - Wix Team
  • annavhart

    Replied by annavhart January 31, 2014

    Hi there,

    I purchased a domain and email through crazy domains, I would like to access my email address through my iphone but am having issues.

    I have updated the Wix MX and A records to be crazy domains ones.

    When I set up a new email should I now put ns1.syrahost.com as the host name?

    Kind regards,

    Anna

    • Tali Wix Team

      Replied by Tali January 31, 2014

      Hey Anna

      I have checked your account and domain, and as you can see according to this tool - your MX records have properly propagated and your mail account is correctly connected.

       

      If you're unable to access your mailbox through your iphone, please contact your email host for further assistance.

      If there are missing records, please add them to the Wix Domain Manager in your Wix account. If you are having trouble with updating your records, please forward us your host’s reply (with the records) and we will make the changes for you.

       

      Let us know if you need any additional help - we'll be happy to further assist, as much as necessary!

      Tali, Wix Team
  • poweroncounselling

    Replied by poweroncounselling January 30, 2014

    I have the wix site published but emails sent via the contact page say that the "owner email address not set"

    I get emails from Wix including the congratulations for publishing the site to the email address I want people to be able to send emails to. Why aren't emails working or does the 72 hour bit apply for new sites?

    • shayb7 Wix Team

      Replied by shayb7 January 30, 2014

      Hey,

       

      To fix this issue simply go to your editor, click the Contact Form, click Settings and fill in your email address under Email To.

  • indonesianlatern

    Replied by indonesianlatern January 26, 2014

    Dear Helpdesk,

    I used my email: indonesialatern@gmail.com as my account, but I forgot my pass. I've tried several times and I couldn't get it thru. So I keep my laptop open with wix account as I worried mu pass would not work. I also tried to change into new email but failed as wix asking the old password that I forgot.

    Would you please help me to change my email indonesialatern@gmail.com into my email: ddprambadi@gmail.com for my new user name, that I rememberd the password?

    Thank you for your help. I really appreciated. 

    Regards

    Didi Prambadi (ddprambadi@gmail.com)

     

    • Ritti Wix Team

      Replied by Ritti January 26, 2014

      Hi,

      Please check out this page for instructions in case:

      - you forgot your password

      - you want to update/ change your password.

      - you forgot the e-mail used to register the account.

       

      Please note- If you are having problems with resetting your password, please follow these steps:
       

      2. Close the Browser and open it again.
      3. Go back to the email we sent.
      4. Click the link.
      5. Click LOAD ANYWAY on the security warning that pops up. 
       
      If you use Firefox or Chrome and you let your browser save your passwords, you can try to retrieve your login details.
      For Firefox, go to Options --> Security --> Saved Passwords.
      For Chrome, go to Options --> Settings--> click on "Show advanced settings" on the bottom of the page --> under Passwords and forms, click Manage Saved Passwords -> click a password -> Show.

      If you want to change your email associated with the account:

      Please go to My Account > under Manage Premium, click Settings.
      Change your username > click Update Personal Details. The changes will get updated automatically.

      Please note that you cannot change your username to one that you have previously used or that someone else is using. It must be a unique username.

      For more information click here or check out the video below:
       

      Please let us know if you need further assistance.

       

      Best, Ritti
  • na3481

    Replied by na3481 January 21, 2014

    Hi my email has not connected i spoke to the guys at crazy domain and they said that you need to do something on your side, need help.

    • na3481

      Replied by na3481 January 21, 2014

      is there anyone going to respond?/??????

       

    • na3481

      Replied by na3481 January 21, 2014

      Hi my MX records are mail.nathanlanham.com

      IP address 27.54.86.65

      please fix as it come up that mail.nathanlanhm.com as  invalid email sever  

    • na3481

      Replied by na3481 January 21, 2014

      its been down four days now.

       

    • Ritti Wix Team

      Replied by Ritti January 21, 2014

      Hi,

      I have made some changes in your Domain records. Please allow for 72 hours to pass in order for the changes to take effect.

      Please let us know should you still have issues with it.

      Best, Ritti
  • an2770

    Replied by an2770 January 17, 2014

    Hi,

    I added my domain name: a-teamgroup.com and MX record: maila32.webcontrolcenter.com to our account yesterday and now the site address is working but our email is coming up as invalid. I have today added the cname entries but I'm not sure if I'm doing this correctly and my mail server is still unresponsive. What should I do?

    Thanks,

    Sharon

    • an2770

      Replied by an2770 January 17, 2014

      My email seems to be coming through and sending in fits and starts now, which is progress, but I seem to have done something to the settings that means that http://mail.a-teamgroup.com/ is now redirecting to http://www.a-teamgroup.com/ instead and I'm not sure which setting I need to change to correct this. Can you please let me know?

    • an2770

      Replied by an2770 January 17, 2014

      I'd appreciate an answer to these questions please as although email is working for some in the company now I still can't access our online email service because of the redirection which is a real hindrance.

    • Michal

      Replied by Michal January 17, 2014

      Hey an2770, 

       

      Thank you for contacting us. Please note that it might take up to 72 hours for the records to propagate before your email is fully functional. That said, it is sometimes necessary to add A records to match the MX records. Please ask your email provider for any A and MX records needed, and send them to us. We will be happy to add them for you. 

       

      Thanks,

      Michal - Wix Team
  • jasoncarpetcorner

    Replied by jasoncarpetcorner January 9, 2014

    Our company owns a domain through Network Solutions in which we use for business e-mail.  We also wanted to use the same domain for the website I'm creating.  However, once I connected this domain with wix.com, we stopped receiving e-mail and this is a HUGE PROBLEM!!!!  I just tried scheduling a support call, but of course that doesn't work either.

    Please help!

    • Ritti Wix Team

      Replied by Ritti January 9, 2014

      Hi,

      You will have to ask your domain host for the full MX records, we can set this for you and you will be able to send and receive all your mail.

      Best, Ritti
    • jasoncarpetcorner

      Replied by jasoncarpetcorner January 9, 2014

      Ok.  I was told that we had two mx records.

       

      1. mail1.verizon.net

      2. mail2.verizon.net

       

      How quickly can this be updated and how soon will our email be back up and running?  In addition, will we lose all e-mails sent to us over the past few days or will they be recovered?

    • jasoncarpetcorner

      Replied by jasoncarpetcorner January 9, 2014

      I was also told that our domain's registrar was pointing our domain to our email provider using the following two name servers...

      1. otherguy.gte.net (ip address 68.238.64.71)

      2. bigguy.gte.net (ip address 68.238.96.71)

       

      I don't know if this helps, but I'm not getting much information from anyone.

    • jasoncarpetcorner

      Replied by jasoncarpetcorner January 9, 2014

      Is it possible to have everything I did with this domain reversed back to its previous settings so we can have our email back and we will just pick a new domain for our website?

    • jasoncarpetcorner

      Replied by jasoncarpetcorner January 9, 2014

      I just wanted to let you guys know that I believe I figured it out on my own after a ton of research.  The MX records were:

      1. mta1.bizmailsrvcs.net

      2. mta2.bizmailsrvcs.net

       

      Thanks for the help.

    • Dima Wix Team

      Replied by Dima January 9, 2014

      Hi Jason,

      I've set the MX records as you requested. Is there anything else we can do for you?

      Dima -Wix support team-
  • alyssadawson

    Replied by alyssadawson January 1, 2014

    Hi, I have transferred my site across (goldcoastfloristrymanagement.com.au) by the DNS. When I contacted our previous website provider I asked for the MX records and he explained to me:

    "Your MX record on the current server is a simple Local Mail Exchanger so you do not have any specific MX records to save/transfer, all you will need to do is set up the same email accounts on your new server and as soon as the new name servers reconcile your email new accounts will be 'live'."

    Our site is now live however we are not receiving emails, when we transferred the site there was a MX record: mail.goldcoastfloristrymanagement.com.au automatically put into MX record (priority=10). 

    Do you know how to fix this? Thanks

    • Nat

      Replied by Nat January 1, 2014

      Hey,

      I am not sure I understand. Would you like us to remove this record?

      Also, please note that Wix is not an email host, which means that you can't do what your email host requests. An alternative to this situation, is to ask the domain host to connect the domain by pointing the A records, and this will keep your regular email functionality.

      Please don't hesitate to contact us again. Nat
    • alyssadawson

      Replied by alyssadawson January 1, 2014

      Thanks, 

      If I don't have access to the MX records (the old computer guy states they don't have any) is there any other way of keeping the current email connected and active? 

       

      Thanks

      Alyssa

    • Rapido Wix Team

      Replied by Rapido January 1, 2014

      Hey Alyssa- who is currently hosting the email?

    • alyssadawson

      Replied by alyssadawson January 1, 2014

      I am unsure, as the previous website designer has told me its a simple mail exchange and we have no MX records for this

    • alyssadawson

      Replied by alyssadawson January 1, 2014

      I am receiving this message: 
      mail.goldcoastfloristrymanagement.com.au
      Invalid email server

    • Rapido Wix Team

      Replied by Rapido January 1, 2014

      Please also ask your host for the corresponding IP address for this record. You can include it here and I will make the changes for you.

  • maumorin

    Replied by maumorin December 25, 2013

    Hello, 

    siteground.com is my email host and they ask me to contact you to do this 

    Mauricio,

    If there is no DNS management tool on their control panel my advice is to contact their technical support and ask them to change the MX record for the domain egopubcrawl.com to:

    siteground186.com

    They should be able to do this without any issues. You can also directly copy this reply to them. They should understand what have to be done by reading it. 

    I wish you Happy Holidays.

    If you need any further assistance do not hesitate to contact us again.

    Best Regards,

    Nikolay Arabadzhiev
    Technical Support Team

    • Alina Wix Team

      Replied by Alina December 25, 2013

      Hey,


      I have updated the MX record for you: 



       

      It may take up to 24 hours for the changes to take effect (propagate). 

      Please let us know should you require any further assistance! 

      Alina, Wix Support Team
  • olander08

    Replied by olander08 December 23, 2013

    my e-mail doesn't work it's olander08.wix.com please help or call me 520-888-5329 mark olander thx

     

    • shayb7 Wix Team

      Replied by shayb7 December 23, 2013

      Hey,

       

      Please note that 'olander08.wix.com' is a part of a Free Wix site's URL and not an email address. Please elaborate and try to be as specific as possible when describing the issue you are experiencing so we could better understand and further assist.

       

      Wix phone support can be scheduled by clicking here
      Please be sure you are logged in to your Wix account and be prepared to provide us with some details of your issue.

Add reply

Mark this reply as Best Reply
Close open child tickets
Post reply