Wix Answers

Do not post confidential info such as passwords or financial information.
Cancel
Post Question
wix Wix Team

Simply click on the page selector on the top of the editor (on the left side).

You can also click on the Pages icon from the left toolbar. Click on the page you want to go to.

Replies(38 replies total)

Show my replies first
  • beskilson

    Replied by beskilson February 28, 2014

    The wix editor is not letting me navigate to any of my website pages. This was not a problem last night. I have cleared my caches and cookies and re-published my site. The issue is occurring in IE, Firefox, and Chrome on two different computers at different locations. My website is mothersmatterdoula.com.

    • Alon - WIX team Wix Team

      Replied by Alon - WIX team February 28, 2014

      we can’t reproduce the problem on our end, please close your current editor session and try again in 10 minutes

      Alon - Wix Team
    • beskilson

      Replied by beskilson February 28, 2014

      That did not fix the problem. I even ran all my computer and browser updates, restarted my computer, and cleared the caches AGAIN. I STILL cannot navigate between any of the pages of my site using either the top or left-hand menu in the editor. The problem occurs in IE 10 and Chrome version Version 33.0.1750.117 m. The attached screen shot shows that I have clicked "FAQ" and am still stuck on the home page. This is extremely frustrating. A wix support person worked on my site to correct another issue yesterday. Did something get corrupted in that process? doc5.pdf

    • beskilson

      Replied by beskilson February 28, 2014

      I just freshly downloaded the latest version of Firefox, and the same problem occurs there. This does not seem to be browser issue.

    • Noa Wix Team

      Replied by Noa February 28, 2014

      Hi,

       

      Our apologies for the inconvenience you are experiencing.

       

      We are currently experiencing some temporary server related issues.

       

      If you are still experiencing problems please reply in this thread and answer the following questions:

      1. Are you able to see your live site? If not, please provide us with its URL

      2. Are you able to access the Editor?

      3. Are you able to access Wix.com?

       

      Thank you for your cooperation, we are terribly sorry for the inconvenience caused to you by this issue. 

      Noa - Wix Team
    • beskilson

      Replied by beskilson February 28, 2014

      Yes, I am still experiencing the problem. The answer to all the rest of your questions is Yes. Looking forward to a solution.

      Thanks,

      Brooke

    • beskilson

      Replied by beskilson February 28, 2014

      Is someone going to address my specific problem as outlined above?? I cannot edit my website, because the wix editor won't allow me to navigate between pages. This has nothing to do with logging in, which is the topic of the thread you asked me to reply to. 

    • Noa Wix Team

      Replied by Noa March 1, 2014

      Hi,

       

      The thread I have asked you to reply to regards all the issues that are caused by our current server problems .

       

      Our technical teams are extensively working on solving all these issues.

      Best and most updated responses will be found in that thread.

       

      Thanks for your understanding.

      Noa - Wix Team
    • beskilson

      Replied by beskilson March 1, 2014

      I don't believe my specific problem is server related. I isolated it to two pages of my website. Deleting those pages and rebuilding them from scratch seems to have solved the issue. 

    • Ilia Wix Team

      Replied by Ilia March 1, 2014

      Hi,

      I'm glad to hear you've worked out your issue. We've been experiencing server issues and we've all but resolved them by now. This may have been caused by these issues and we are making sure that this does not repeat.

      Please let us know if the issue occurs again or if you have any other questions.

       

      Best regards

      Ilia - Wix Support
  • jeffscotphilips83

    Replied by jeffscotphilips83 February 22, 2014

    Hey, editor is not letting me navigate to any of my pages other than "Home", I'm using Chrome, I've cleared my cookies & cache, and I still can't reach any other pages for editing.

    How can I fix this?

    • Anat Wix Team

      Replied by Anat February 22, 2014

      Hey,

       

      Please try to publish your site again and let us know if the problem persists.

      In addition, please let us know which components you have on the "meals and pricing" page (apps, blog, list, html code etc.) since it seems this page is causing the problem

      Thanks,

      Anat - Wix Team
    • jeffscotphilips83

      Replied by jeffscotphilips83 February 22, 2014

      Thanks Anat - I published & refreshed my page, but it's still not letting me navigate to any other pages other than "Home".

       

      The only components I have on the "meals and pricing" page are wix buttons, text, a link to another wix page (menus), and on every page I have an HTML box for my opt-in.

    • Ilia Wix Team

      Replied by Ilia February 22, 2014

      Hi,

      Please note that most of your pages are hidden.

      Please follow these steps:

      1. From the left toolbar, click the Pages icon to open the Page Manager.
      2. Next to your page, click the settings icon.
      3. In the Settings and SEO window, uncheck the box next to Hide from menu.
      4. Click Done.

       

      Best regards

      Ilia - Wix Support
    • jeffscotphilips83

      Replied by jeffscotphilips83 February 23, 2014

      llia, I understand how to do that, the problem is that I cannot access any other pages - in editor - other than the home page. I wasn't having this problem two days ago - something has changed...


      Here is a video screenshot of what I'm talking about. 
      http://screencast.com/t/FVVwIvvJl3Y0 
      Note how the page never changes, so I can no longer make edits to my wix website.

    • Dror - Wix Support Wix Team

      Replied by Dror - Wix Support February 23, 2014

      Hi,

      This sounds like some sort of issue with a corrupt element on your site. Does this issue occur with one specific browser? 

      We recommend you to try and use different browsers and see if there is any difference.

      Wix supports all major browsers (including IE, Firefox, Google Chrome and Safari), and all of those browsers support the ability to export favorites and bookmarks to the newly installed browser.

      To download the latest Google Chrome browser please click here
      To download the latest Firefox browser please click here
      To download the latest Safari browser please click here
      To download the latest Internet Explorer browser please click here
       
      Awaiting your reply, 
      Dror - Wix Team
  • rgweston33

    Replied by rgweston33 February 20, 2014

    Hello,

    Please can someone look into why the product I am paying for does nor work?

    All details are in my previous post.

    • Hudson Wix Team

      Replied by Hudson February 20, 2014

      Please use another browser other then EE 

      Either Firefox or Chrome 

      To download the latest Google Chrome browser please click here
      To download the latest Firefox browser please click here
       
      I have viewed your site and editor and could not recreate any of the issues  either in the editor or live version. 
    • rgweston33

      Replied by rgweston33 February 20, 2014

      Yes it is working now because I basically had to delete half of my website to find the problem and then spend my morning recreating it. 

      Why do all wix team members just reply to a query with a painfully patronizing response which assumes no knowledge of  a computer? And their simplistic reply is usually a result of their not reading of the original post. In this case, I stated clearly that I have tried Chrome, Firefox and IE. I then answered (AFTER I had mentioned what browsers I have used) that my ISP is called EE (NOT BROWSER - THERE IS NO BROWSER CALLED EE).

      Thankfully I have now sorted the bug out myself by deleting half of my site so I do not need anymore "support". For goodness sake please can you people actually read a person's post before offering a substandard reply?!

      Goodbye

  • renatosolpietro

    Replied by renatosolpietro February 20, 2014

    Hi,I can only see my homepage. Something must be wrong...can you help please?

    • Uma - Wix Team Wix Team

      Replied by Uma - Wix Team February 20, 2014

      Hi, All the components on your homepage are set to appear on all pages. Please make sure this option is not checked (in Settings or in the small floating menu after clicking on the image). Please note the black strip is also set to appear on all pages on your home page.

      Should you require further assistance please let us know.

      Thanks!

  • rgweston33

    Replied by rgweston33 February 19, 2014

    Hi,

    I am having the same problem as a few other people on here: I can only see my homepage even though I have selected another page in the editor. I have tried all of the steps outlined on the help page (http://www.wix.com/support/main/html5/wix-editor/other/dealing-errors#weight-1), and here is the information requested on that page after following those steps:

    1. Windows 7

    2. Chrome (32.0.1700.107 m); Internet explorer (11.0.9600.16518); Firefox (27.0.1)

    3. rgweston33; grainandleaf

    4. screenshots:

    5. London; EE

    6. None

    • ilan-t Wix Team

      Replied by ilan-t February 19, 2014

      Hello,

       

      The major components on your home page have been set to show on all pages, making them all look the same and therefore as though you can't switch page.

       

      Simply click on each component then make sure to un-tick the option show on all pages and that should resolve the issue for you.

       

      Best regards

    • rgweston33

      Replied by rgweston33 February 19, 2014

      No, I have had a look into that and it seems you have mistakenly taken a symptom to be the cause. My whole editor is messed up and is showing on all pages except the home page that the major components are set to be shown on all pages. When I untick this box it just deletes the component from the entire website (including the homepage), and it then won't allow me to add new components. Please can someone look again and try and figure out why my editor is broken (my actual live website is fine and looks the same as it did before)?

  • joinrcet

    Replied by joinrcet February 18, 2014

    i am editing my website  and add pages first time but now my page option is not working as all of other are working like design ,insert , setting and apps etc

    • Alon - WIX team Wix Team

      Replied by Alon - WIX team February 18, 2014

      it was a temporary glitch, everything should work as expected now

      Alon - Wix Team
  • JCheswick

    Replied by JCheswick February 15, 2014

    THanks KAren

    I wasn't able to get working in Chrome or any oterh browser on Mac.

     

    However wheat did RESOLVE the issue for me was this:

    I copied my entire website and then transferred the new copy to my domain.

    I deleted the original website and continued working on the copy.

    Thanks for all of you help

    Regards Jai

    • ilan-t Wix Team

      Replied by ilan-t February 15, 2014

      Hi Jai,

       

      Glad you were able to figure it out, feel free to contact if you encounter any other issues.

       

      Best regards

  • JCheswick

    Replied by JCheswick February 15, 2014

    Alina,

    Any news Alina or is it something to go into the too hard basket ?

    Thanks Jai

  • JCheswick

    Replied by JCheswick February 14, 2014

    Hi Alinna

    Thanks for swift reply. Here a a couple of screenshots that show the issue. 

    Alos in preview cannot move between pages so essentially I am stuck on home page.

    I've cleared cache, switched off computer, etc etc.

    Thanks Jai

     

    • Keren Wix Team

      Replied by Keren February 15, 2014

      Hey,

       

      Thank you for contacting Wix support! I entered your editor using Google Chrome and was not able to recreate your matter. I was able to browse through the pages using both the menu as well as from the page scroller at the top of the editor. 

      Please try some of the solutions provided here to make sure that your issue is not a local one.

      Make sure to try different browsers, connections and devices.

      If the steps in the link didn't resolve your issues, please answer the questions in the same link.

      Thanks,

      Keren, Wix Support
  • JCheswick

    Replied by JCheswick February 14, 2014

    Hi

    Ive been using six for years. I now how to use. 

    Suddenly I am unable to move between pages in editor ( html5).

    The page indexes both show that I have change pages but the page remains the same.

    Urgent response required please

    Regards Jai

     

    • Alina Wix Team

      Replied by Alina February 14, 2014

      Hey Jai,

      I am sorry you are experiencing difficulties. 

      Please elaborate on the issue so we can better understand it and help you solve it. On which site of your sites does this issue occur? Which pages are you trying to open?


      Please provide us with a screen shot of the problem. For instructions on how to take a screenshot, please use this link.
       

      To upload the screenshot, simply click on the "Upload" button and follow the steps.
       

      Thanks, 

      Alina, Wix Support Team

Add reply

Mark this reply as Best Reply
Close open child tickets
Post reply