Wix Answers

Do not post confidential info such as passwords or financial information.
Cancel
Post Question
wix Wix Team

To hide a page from your navigation menu: From the left side of the Editor, click the Pages icon > click the Settings wheel for the relevant page > in the Settings and SEO window, check the box next to Hide from menu > click Done.


Note: Your site visitors will be unable to access hidden pages unless you link to them.


For more information about pages, please click here or watch the video below.
 

Replies(51 replies total)

Show my replies first
  • statenislandfilm

    Replied by statenislandfilm July 7, 2014

    Menu Not Hiding Pages Its Supposed To

    The editor I am using is saying that the selected "landing" page is hidden from the menu, but when it publishes, it appears there. When I log out and log back in and relaunch the editor, the "hide menu" box is once again unchecked. I'm saving and all that hubbub - any bright ideas?

     

    Thanks!

    • Tal Wix Team

      Replied by Tal July 7, 2014

      Hi statenislandfilm,

       

      Thank you for contacting Wix support team.

      I was able to hide the "landing" page from the main menu bar:

      http://statenislandfilm.wix.com/thespaceship

       

      In case this issue persists, please clear your browser's cache and give it another try. You can find "How to clear cache" instructions here.

       

      Please don't hesitate to contact us for any further assistance,

      Tal, Wix Team
  • sheldonphelan

    Replied by sheldonphelan July 4, 2014

    Good day

    I want to launch a section of my site at a later stage, when I go to publishing how do I prevent that page from going live and when the time comes, how would I make the page active?

    Thanks

    Sheldon

    • Leah Wix Team

      Replied by Leah July 4, 2014

      Dear Sheldon,

       

      To hide a page from your navigation menu: From the left side of the Editor, click the Pages icon > click the Settings wheel for the relevant page > in the Settings and SEO window, check the box next to Hide from menu > click Done.


      Note: Your site visitors will be unable to access hidden pages unless you link to them.

       

      To hide an individual page from search engines: From the left side of the Editor, click the Pages icon > next to the relevant page, click the Settings wheel > under SEO Page Settings, check the box next to Hide page from search results


      For more information about pages, please click here or watch the video below.

       

      I  hope this helps! Please let us know if we can assist you further.

      Sincerely, Leah Wix Team
  • teamcloud

    Replied by teamcloud July 3, 2014

    Hello,

    I would like to make a subpage that wont't appear in the menu, but if i copy this hidden subpage's URL, we could open it.

    Is it possible?

    • Ben Wix Team

      Replied by Ben July 3, 2014

      Please note that you can accomplish this by following the instructions outlined in the above best reply to hide the page from your menu.

       

      You can find out the exact URL of every page of your site, including pages hidden from the menu, by accessing the sitemap.

       

      Every Wix creation has an XML sitemap that assists in getting content recognized by search engines (and Google Analytics). The sitemap is dynamically generated within our server and, therefore, stays up to date with any pages that you add or remove from your site.

       

      To view your sitemap, add sitemap.xml to the end of your domain name. Example: mydomainname.com/sitemap.xml

       

      Note: If you cannot see the Sitemap, please make sure that you have selected to 'Allow search engines to find my site' from within your site SEO settings.

       

  • Léa Wix Team

    Replied by Léa July 3, 2014

    Hi Anita,

     

    Yes you can make sub pages that don't appear in the menu by hiding pages from your menu.

    I transferred your question to the relevant thread.

    You will find instruction in the blue box.

     

    Thank you for contacting us

    Pensez à vous abonner à notre chaîne Youtube pour visionner tous nos tutoriels : https://www.youtube.com/channel/UCy7ONifkKb8_cWLWgjub7Mg Léa - L'Équipe Wix -
  • britanniakent

    Replied by britanniakent July 3, 2014

    My premium site will not load

    My primium site thebritanniakent.com will not load!!! all paid up to date, cannot edit it. Urgent what the hell is going on!!!

  • teamcloud

    Replied by teamcloud July 3, 2014

    Subpages that wont appear in the menu

    Dear Wix Team,

    Could I make subpages that don't appear in the menu, but if i put those page's links, the visitor can see it?

    Thank you for your help,

    Anita Perendi

  • atlasdesign

    Replied by atlasdesign July 1, 2014

    HELP! Getting so irritated. It says they are hidden but they still appear on the NavBar. I have tried unhiding and hiding. closing my browser. various browsers. it seems to work for a bit then next time the site loads they are visible. I am annoyed at how buddy the Wix service I pay for has been. Problem after problem. Seems like you need to fix wix before selling the service. It's bugging me, Please fix it NOW as I am waiting to start taking money and it's not happening... HELP NOW PLEASE!

    • atlasdesign

      Replied by atlasdesign July 1, 2014

      I need ''DESIGN'' and ''PRINT'' Hidden as they are under the ''SHOP'' page. Also I meant 'Buggy' not ''buddy'' 

       

      cheers 

       

       

    • Daniel Wix Team

      Replied by Daniel July 1, 2014

      Hi,

       

      I viewed your site and these pages were not set to be hidden from your menu.

      While browsing on the web, your computer and browser stores various information. This build up of information can sometimes cause conflict.

      Please clear your browser's cache and try again. You can find step by step instructions here.
       

      If you are still able to see these pages, try removing your menu and adding it again.

       

      Daniel - Wix support team
    • atlasdesign

      Replied by atlasdesign July 1, 2014

      I understand. I didn't think to empty the cache. I will be sure to in the future. Thanks 

    • Miki- Wix Team Wix Team

      Replied by Miki- Wix Team July 1, 2014

      Great!

       

      Let me know should you need further assistance.

      Best regards, Miki- Wix Support Team
    • atlasdesign

      Replied by atlasdesign July 3, 2014

      Hey. I did everything. Cleared my entire cache as well as history. Also tried the changes on a friends laptop and it's still showing the same thing. It is showing the hidden pages even though they are hidden. it is important this is fixed but i do as I have tried changing hiding the pages on my iphone, windows laptop and macbook. Please advise. 

    • Or Y Wix Team

      Replied by Or Y July 3, 2014

      Please make sure you save and publish your changes.

      I have turned these pages hidden, saved but not published - they are still defined hidden in the Editor. If you wish, you can publish your site.

       

      Please let us know in case you need further help.

      All the best, Or
    • atlasdesign

      Replied by atlasdesign July 3, 2014

      I have worked on this site for a while you can see I know how to publish the site. I don't think I have ever saved without publishing. Please feel free to log in and publish my site and see what happens for yourself. This problem is never ending

    • Or Y Wix Team

      Replied by Or Y July 3, 2014

      Hello,

       

      I have published the changed. This is how your menu is displayed in your live site at the moment:

       

       

      Please let us know in case you need any further help.

      All the best, Or
    • atlasdesign

      Replied by atlasdesign July 3, 2014

      Refresh the page. it is back to 6 pages. no idea why but do you have any other advise. I am an i.t. technician as designer so i know how this stuff works but it is a fault. nothing more. please refresh and check back

    • Or Y Wix Team

      Replied by Or Y July 3, 2014

      Hello,

       

      If you are still having trouble viewing your site, please try doing the following:

      1) Go here and click on "Delete all sites". Then clear your browser's cache.

      For step-by-step instructions about how to clear your browser's cache, please follow this link.
      You can also find a video tutorial here.

      2) Try to Flush your DNS. For detailed instructions on how to do so please go here.

      3) Please go to the Windows start menu->click on 'run'-> select the first option: 'Run'-> type: 'ping yourdomain.com'->A window will pop with an IP address. Please run this test from several computers.

      For Mac users: Go to ‘Application’ then open ‘Terminal’ and type: 'ping yourdomain.com'->A window will pop with an IP address. Please run this test from several computers.

      -If you receive an IP address on your computer other than the IP you see here and you see this IP from other computers please contact an IT expert in your area for further troubleshooting.

      -If you receive a different IP than the IP you see here from multiple locations, please send it to us in order for us to check it.

      All the best, Or
    • atlasdesign

      Replied by atlasdesign July 6, 2014

      This is all so rubbish. Did everything you said and it's still the same. I have tried from different locations. I have now tries on my laptop at home. Pc at mothers house and my laptop at my mother house. as well as my girlfriends laptop and my iphone. This CAN'T be my issue... Surely?

    • Or Y Wix Team

      Replied by Or Y July 6, 2014

      Hello,

       

      I have noticed that you deleted the page Shop. The two pages were unhidden when I entered your Editor. I re-hid them, saved and published.

       

      In case the issue persists, we would like to further investigate the issue. Please take a few screenshots of your sites on a few different sources.

       

      For instructions on how to take a screenshot, please use this link.

       

      To upload the screenshot, simply click on the "Upload" button and follow the steps.
       

       

      All the best, Or
  • Ritti Wix Team

    Replied by Ritti June 17, 2014

    Hi,

    I could see that all of the 3 sites were hidden - meaning they cannot be found on the menu. The hidden pages are working as expected.

    Please let us know if there is anything else we can help you with.

    Best, Ritti
  • Cruiseology

    Replied by Cruiseology June 17, 2014

    The outcome I want is for all three pages to be hidden, please.

    • Cruiseology

      Replied by Cruiseology June 17, 2014

      Hi Ritti,

      Thank you for following up. The issue seemed to correct itself.

       

    • Rapido Wix Team

      Replied by Rapido June 18, 2014

      Cheers! Enjoy your Wix :)

  • Cruiseology

    Replied by Cruiseology June 17, 2014

    This is what happens when I have the 'Hens At Sea' Bucks At Sea' and 'Propose At Sea' pages hidden - the Hens page and the Propose page are successfully hidden, but the Bucks page will not hide, despite resaving, republishing and refreshing. This problem has been occurring for the past 2 days.

Add reply

Mark this reply as Best Reply
Close open child tickets
Post reply