Wix Answers

Do not post confidential info such as passwords or financial information.
Cancel
Post Question
CarleyS Wix Team

Update: We have some exciting news!

We are pleased to announce that we have released our new multi-content blog feature! You can now add multiple images or videos to your blog posts. This also means that you no longer need to choose a post type when creating your posts.

 

You can add images and videos to your post, at any time, through the Post Editor. 

 

To add a multi-content blog post: Click your blog to select it > from the pop-up menu, click Add & Edit Blog Posts > click Add.

To add an image: From the Post Editor, click the Image icon (as can be seen in the screen shot below) > select existing images or upload a new one > click Add Images.

To add a video: From the Post Editor, click the Video icon (as can be seen in the screen shot below) > enter the YouTube URL of the video.

In the Post Editor, click the space above or below the image to continue editing > to add additional images or videos, click the Image or Video icon again and repeat the steps above.


Note: It is not possible to add multiple images or videos to older blog posts which you created before this feature was released.

 

We'd like to take this opportunity to thank you for your patience while waiting for this feature.

To learn more about this feature please watch the video below:

- Regards, Carley

Replies(1,158 replies total)

Show my replies first
  • lalkobefan8

    Replied by lalkobefan8 July 15, 2014

    Adding Posts

    My website is www.pitch.gallery

    For some reason it is not allowing me to add another photo post. I have never had this problem before.

    Please help!

    • AlonH Wix Team

      Replied by AlonH July 15, 2014

      Hi, 

       

      Iv'e merged your issue with the relevant topic.

      Please note that we have made some changes in our blog platform. Take a look at the Best Answer above. 

       

      Don't hesitate to contact us if you need any further assistance. 

  • smitty1923

    Replied by smitty1923 July 15, 2014

    By the way, when I click the add button, the editor just brings me to the post editor, skipping the normal option to select the type of post to compost. 

  • smitty1923

    Replied by smitty1923 July 15, 2014

    Add Photo Post option gone

    Hello. The option to add a photo blog post in the Wix editor is gone. I've tried to find it in Safari and Chrome. When I click the Add button to add a new post, I don't get the photo, video or text post options. Please help. Thanks!

    • rony Wix Team

      Replied by rony July 15, 2014

      Hi, 

      I have merged your question with the relevant thread.

      Please refer to the best reply above.

      All best, 

      Rony WixTeam
  • legendrevalerie1 Premium VIP

    Replied by legendrevalerie1 July 14, 2014

    Unable to add photo post

    My wix editor is no longer allowing me to add photo posts on my blog. My website is www.bringonfit.com and I have the VIP plan. Can you please help me with this? Thank you!

     

    Valerie 

    • Elia Wix Team

      Replied by Elia July 14, 2014

      Hi Valerie,

      We've recently updated our Blog platform, and you're welcome to check out the 'best reply' for this topic in order to learn more about these exciting new features.

      Should you require further assistance or information, please let us know,

      Elia - Wix Support
  • kennethodibe

    Replied by kennethodibe July 13, 2014

    Ok, I tried that but it only allows me to have one image (http://www.crystalkenphotography.com/#!Bola-Ezekiel-Traditional-Wedding-Thursday-19th-June-2014/c1omg/1)

    However, I want it to be like this (http://ositanwegbu.com/blog/) so that I can scroll down. it wont let me do it now. can you advise how I can upload more than one image on an image blog?

    Thanks

    Ken

    • Itamar S Wix Team

      Replied by Itamar S July 13, 2014

      Hi,

       

      I moved your question to the relevant thread. Please read the Best Answer above.

       

      We are here should you require any further assistance.

  • katherineejolly

    Replied by katherineejolly July 13, 2014

    This feature is great and I am glad to see that is has finally been added. It makes blogging (especially fashion blogging) that much easier. However, this is what I noticed. I just created a post with a title, followed by 9 images, followed by text. However, when I preview this is what it shows... the title, followed by the first image only and then the text. In order to see all the photos you have to click on the picture. Why is this? Why doesn't the post display all the photos before showing the text? It makes it very confusing for the reader. Is there a way to change these settings. Right now, I have to "trick" the system by creating a new post for each individual picture and using the space bar as characters for the title. It is quite frustrating. I love this program and feel that WIX has good options but very little things have become very big things. I hope you can help. Thank you!

    • Ritti Wix Team

      Replied by Ritti July 14, 2014

      Hi,

      I could see all of your images in the post.

       

      While browsing on the web, your computer and browser stores various information. This build up of information can sometimes cause conflict.

      Please clear your browser's cache. You can find step by step instructions here.
       

       

      Best, Ritti
  • schdror

    Replied by schdror July 13, 2014

    blog images

    hi .

     when starting a new blog post i was able to choose either photo/text or video blog 

    now when clicking "new" im only able to create text post 

    what got wrong ? 

     

    • Etti Wix Team

      Replied by Etti July 13, 2014

      Hi,

       

      I have merged your query with the relevant thread.

      Please refer to the best reply above.

       

      Let us know if you have more questions.

  • mrerickblack

    Replied by mrerickblack July 12, 2014

    photo posts

    Hi, I was able to add a photo post to my blog before. I would have an option to add/upload a picture on the right corner of the window. But now everytime I add a new post, it sets an text post and no option appears anymore like it used to. Now the only way I can add an image is within the text of the post but when I do that it doesnt show on my website after it is publised. can you please help? below is an image of how my new posts appear with atT for text on them...

    • Nati Wix Team

      Replied by Nati July 13, 2014

      Hey mrerickblack,

       

      Thank you for contacting Wix support.

       

      Please note that I have merged your post into the relevant thread regarding this matter; please refer to the Best Reply on top of the page.

       

      We are here should you require any further assistance.

      Best Regards, Nati - Wix Support Team
  • paradoxthis

    Replied by paradoxthis July 12, 2014

     

    I am pleased with the platform, but i would like to insert a picture in the "text" portion and there is not an icon.  I am not sure if it is relevant, but it is a photo post.  I am having to hyper link a text to a document when I would just like to insert an image…is that possible?

    • Alina Wix Team

      Replied by Alina July 12, 2014

      Hey,

      I have visited your site's editor and the multiple images option was properly displayed on my end as you can see below:



      While browsing on the web, your computer and browser stores various information. This build up of information can sometimes cause conflict.


      Please clear your browser's cache. You can find step by step instructions here.
       

      Thanks, 

      Alina, Wix Support Team
  • reangilbert

    Replied by reangilbert July 11, 2014

    hI, THIS is not working for me. I cannot add multiple photos to one blog, the little button in the post editor is not there for me? I am using the HTML editor.

    • Alina Wix Team

      Replied by Alina July 12, 2014

      Hey,

      I have visited your site's editor and the multiple images option was properly displayed on my end as you can see below:



      While browsing on the web, your computer and browser stores various information. This build up of information can sometimes cause conflict.


      Please clear your browser's cache. You can find step by step instructions here.
       

      Thanks, 

      Alina, Wix Support Team
    • Tomer Wix Team

      Replied by Tomer July 13, 2014

      Additionally to Alina's answer, please be sure you are writing a NEW post and not UPDATING an old one.

      This feature works only for new posts.

      Tomer Grencel Product Manager, Blog Team

Add reply

Mark this reply as Best Reply
Close open child tickets
Post reply