Wix Answers

Do not post confidential info such as passwords or financial information.
Cancel
Post Question
Uma - Wix Team Wix Team

@ seethestars,

Please make sure you have ticked the box next to "Let the search engines find my website" in your Settings > Site Optimization. Please  also make sure you update your meta tags. Find more here

You can also try submitting your site to Google. Click here for more information.

You can read more about SEO here and try out our SEO Monitoring Tool.

Thanks,

Uma@WIX

Replies(3 replies total)

Show my replies first
  • Master Yoda

    Replied by Master Yoda May 8, 2012

    Hello seethestars ,

     

    I see that Google has not cached your web-site, which is a bit bizarre but it's up to Google when their robots get to scan and index a user's site! It's the same for all newly submitted sites world-wide, not just Wix!

     

    Please follow these links to re-submit your site to search engines!

     

    Submit your website to the following search engines by clicking on the links: Google or Bing.

     

     

    All the best!

  • seethestars

    Replied by seethestars May 7, 2012

    I have checked, I did all the things you mentioned 4 months ago, and I made sure I have ticked the box. But I still can not search my website in google. Could you please help me to solve this problem?

  • Uma - Wix Team Wix Team

    Replied by Uma - Wix Team May 3, 2012

    @ seethestars,

    Please make sure you have ticked the box next to "Let the search engines find my website" in your Settings > Site Optimization. Please  also make sure you update your meta tags. Find more here

    You can also try submitting your site to Google. Click here for more information.

    You can read more about SEO here and try out our SEO Monitoring Tool.

    Thanks,

    Uma@WIX

Add reply

Mark this reply as Best Reply
Close open child tickets
Post reply