Wix Answers

Do not post confidential info such as passwords or financial information.
Cancel
Post Question
  • AJBCPhotography

    .png not transparent

    By AJBCPhotography January 15, 2012

    Locked by moderator

    Main Category : Editor

    Sub Category : Pictures

    Ticket # : 929174483

    Ticket Status : Closed - User did not react

    I have uploaded a .png file (saved with a transparent background) to my site, removed the frame on it, and the background is still white, not transparent. Why? Please help. I have uploaded .png files before and it has worked. 

Replies(14 replies total)

Show my replies first
  • johnkelleya

    Replied by johnkelleya April 25, 2014

    Im experiencing the exact same problem!! I have a PNG that I've used on my site and it is transparent, but if i add it again it makes the background grey? all of the sudden! Help 

    • Ira Bel Wix Team

      Replied by Ira Bel April 26, 2014

      Hello,

       

      Please notice that you have HTML sites and you are you've posted your question in Flash forum.

       

      Please elaborate, which of your three sites are you referring to?

  • table3media

    Replied by table3media July 3, 2013

    Look, when you upload a .png with no background, the facebook designer on wix will not see that it has no background. It comes in with a black background. 

    • Daniel Wix Team

      Replied by Daniel July 3, 2013

      Hi,

       

      The background that you are seeing is probably the image's border. You can remove it by editing the image's style and changing the border color's opacity to 0.

      Daniel - Wix support team
  • Avi Wix Team

    Replied by Avi February 26, 2012

    Hello AJBCPhotography,

     

    Please upload those 2 files to this thread. I would like to see the files you are referring to .

  • AJBCPhotography

    Replied by AJBCPhotography February 25, 2012

    Those images you see that are "jpg" were working for me the way a .png should. Then I decided to move them on the site and once moved, the background appeared. The .png was working just fine, for months, and then all of a sudden, new .pngs and old .pngs that were moved were not working properly. I would appreciate if the help section of wix actually investigated this problem properly...

  • AJBCPhotography

    Replied by AJBCPhotography February 25, 2012

    Sorry- but that's impossible. Clearly there is a problem with wix bc the files ARE .png and they WERE saved transparent. Believe me- due to the issues I was having I re-saved them and re-uploaded both images over and over to MAKE SURE!

  • dinamiso Wix Team

    Replied by dinamiso February 25, 2012

    Hi AJBCPhotography,

    I checked your site and I saw the problem.

    Please make shure you saved this photos as a .PNG format.

     

    If you upload your image as a JPEG, it will always have a solid color background,
     most likely white. If you wish to upload an image with no background, 
    Also, please check you saved this photos as a transparent .PNG file. 
     
  • AJBCPhotography

    Replied by AJBCPhotography February 24, 2012

    www.ajbcphotography.com
    I have an "enter page" that takes you to the rest of the site. It's on the main site. 
    There are 2 link button, a "facebook" and a "blog" one. They are currently in the upper right hand corner and look to be transparent, bc they are agains't whit, but if you move them onto any color you can clearly see they aren't. Even after you click "no frame" is still has a white box. Thanks for the help!

  • Nadav

    Replied by Nadav February 24, 2012

    @AJBCPhotography,

    Please specify on which site and page you are having trouble with the .png's so we can look into it.

     

    Nadav - Wix Team
  • AJBCPhotography

    Replied by AJBCPhotography February 23, 2012

    Simmie, 
    Can I ask you what you did?
    NO .png files are working for me currently, even after I remove the frame. 
    I currently have them on my site in places that it makes no difference if the background is transparent or not, but I hate the fact that if I ever want to relocate a .png file I can't bc it will have an ugly white box around it. Even .png files that worked previously on my site, if I re-upload them, they don't work now either, so clearly it's not me...
    Any help is appreciated.  

  • Slimmie

    Replied by Slimmie February 23, 2012

    nvm, sorted it out :)

Add reply

Mark this reply as Best Reply
Close open child tickets
Post reply