Wix Answers

Do not post confidential info such as passwords or financial information.
Cancel
Post Question
  • mwdowiak33

    Disable auto loop for swf file

    By mwdowiak33 April 8, 2012

    Locked by moderator

    Main Category: Editor

    Sub Category: Other

    Ticket #: 342429230

    Ticket Status: Closed - User did not react

    Recently I have downloaded .swf file to my website after meeting all your rquirenments ( seems like you make it as difficult as possible so users do not download their own swf).  The original file has auto loop disabled, meaning: movie with audio plays once and it stops but when I placed it on wix - it plays constantly like in auto loop.  I was trying to find the setting to disable it but there is nothing there - only settings for display.  The audio from the .swf is interfiring with my other audio/movie links I have on main pages.

Replies (11 replies total)

Show my replies first
  • Elia Wix Team

    Replied by Elia August 25, 2012

    You can try to add this functionality using our HTML widget: An answer to this topic can be found in Adding HTML to a Wix Site.

     

     

    If the HTML widget isn't working, it may be a problem with the code.
    You can check if the code is correct by using this site.
     
    Simply paste the html code between <body> RIGHT HERE </body> and click
    the button above (Edit and Click Me) in order to see the results.
     
    If nothing appears in the right window or a certain component appears
    but doesn't work, this means that the code is problematic. Please
    contact the creator of the code and let them know that it isn't
    working.
     
    If the preview shows the content as expected, then it's a
    compatibility issue with Wix. We're currently working on improving the
    compatibility of Wix with customizable code.
    Elia - Wix Support
  • jdndesigns

    Replied by jdndesigns August 24, 2012

    Most of what I want to show on my site is swf files. If all swf files loop when in the site, this is a serious problem. Also I would like to know if you realise how limiting this is (any file with audio continues to play, even after moving to another page.  Any response would be appriciated!

    Does Wix overide the setting in a Flash file? Does it defalt to "Loop" in playback?

  • mwdowiak33

    Replied by mwdowiak33 August 21, 2012

    Unfortunately because of this - you will start loosing more business by creating size limitation and not supporting simple issues like this one. 

  • Omer Wix Team

    Replied by Omer August 21, 2012

    Unfortunately we are unable to provide support on SWF files that users upload and are not a part of Wix's products.

  • jdndesigns

    Replied by jdndesigns August 21, 2012

    I have the same problem. Swf files loop. I have put a "stop" in the action script but it still loops and continues to play the audio after I have left the page....this realy is not good.....help

  • Elia Wix Team

    Replied by Elia April 12, 2012

    It means it is in the code of the .FLA file that created the SWF.

    Elia - Wix Support
  • mwdowiak33

    Replied by mwdowiak33 April 11, 2012

    Ok - what do you mean by "break"?

    The original .swf file is already created so the video and audio plays only once - auto loop is disabled.

    I tested it before I uploded it to my website.

  • Omer Wix Team

    Replied by Omer April 11, 2012

    You need to add a "break()"; to the code of your SWF. That should stop it from looping.

     

    It is not possible to effect the SWF file from the editor.

  • mwdowiak33

    Replied by mwdowiak33 April 11, 2012

    The point is: I want to keep my .swf file on main page playing video and audio only once not continuosly.  When I remove my .swf file - the audio stops obviously because the file is no longer there.

    My .swf file contains video and audio combined together so it is synchronized.  I can remove the audio from video and download it as 2 different files but I might have some synchronization issues when the page loads.

    My .swf file is set to play once - why not include the option in settings for auto loop or not auto loop.

    Thanks

    Mark

     

  • Elia Wix Team

    Replied by Elia April 9, 2012

    You should remove the SWF from the editor and save.

    Reopen your editor or live site... if the music still plays and the SWF isn't in his site, then let us know.

    Elia - Wix Support

Add reply

Mark this reply as Best Reply
Close open child tickets
Post reply